# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 69897-AVSalvansRB2011LS going to be executed."
#
# Configuration for RouterOSv6.x
# Trasto: 69897-AVSalvansRB2011LS
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=AVSalvansRB2011LS
#
# DNS (client & server cache) zone: 8595
/ip dns set servers=10.139.197.34,10.138.65.226 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 8595
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.3.66
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="AVSalvans" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 AVSalvansAP0
/interface wireless set wlan1 name="wlan1" \
radio-name="AVSalvansAP0" mode=ap-bridge ssid="guifi.net-AVSalvansAP0" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5180 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.91.186.1/27"] do={remove $i}
/ ip address add address=10.91.186.1/27 network=10.91.186.0 broadcast=10.91.186.31 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.91.186.0/27] do={/routing bgp network remove $i;}
add network=10.91.186.0/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.91.186.0/27] do={/routing ospf network remove $i;}
add network=10.91.186.0/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.91.186.7-10.91.186.30
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.91.186.0/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.91.186.0/27 gateway=10.91.186.1 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
#
# Radio#: 1 AVSalvansAP1
/interface wireless set wlan2 name="wlan2" \
radio-name="AVSalvansAP1" mode=ap-bridge ssid="guifi.net-AVSalvansAP1" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5240 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.94.161/27"] do={remove $i}
/ ip address add address=10.138.94.161/27 network=10.138.94.160 broadcast=10.138.94.191 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.94.160/27] do={/routing bgp network remove $i;}
add network=10.138.94.160/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.94.160/27] do={/routing ospf network remove $i;}
add network=10.138.94.160/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=10.138.94.167-10.138.94.190
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.94.160/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.94.160/27 gateway=10.138.94.161 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.94.162 mac-address=00:00:00:00:00:00 client-id=AVSalvansAP1 server=dhcp-wlan2
add address=10.138.94.163 mac-address=00:00:00:00:00:00 client-id=AVCoromina server=dhcp-wlan2
add address=10.138.94.164 mac-address=00:00:00:00:00:00 client-id=AVMia server=dhcp-wlan2
add address=10.138.94.165 mac-address=04:18:D6:44:DA:0F client-id=AVMGraus server=dhcp-wlan2
#
:delay 1
#
# Radio#: 2 AVSalvansAP2
/interface wireless set wlan3 name="wlan3" \
radio-name="AVSalvansAP2" mode=ap-bridge ssid="guifi.net-AVSalvansAP2" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5300 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.94.193/27"] do={remove $i}
/ ip address add address=10.138.94.193/27 network=10.138.94.192 broadcast=10.138.94.223 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.94.192/27] do={/routing bgp network remove $i;}
add network=10.138.94.192/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.94.192/27] do={/routing ospf network remove $i;}
add network=10.138.94.192/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=10.138.94.199-10.138.94.222
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.94.192/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.94.192/27 gateway=10.138.94.193 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.94.194 mac-address=00:00:00:00:00:00 client-id=AVSalvansAP2 server=dhcp-wlan3
add address=10.138.94.195 mac-address=00:00:00:00:00:00 client-id=AVGavarro server=dhcp-wlan3
add address=10.138.94.196 mac-address=00:15:6D:E9:DF:4E client-id=AVLaCoromina2 server=dhcp-wlan3
add address=10.138.94.197 mac-address=00:00:00:00:00:00 client-id=AVMasclet server=dhcp-wlan3
add address=10.138.94.198 mac-address=00:00:00:00:00:00 client-id=AVAljubRd1 server=dhcp-wlan3
add address=10.138.94.199 mac-address=00:00:00:00:00:00 client-id=BRGElies server=dhcp-wlan3
add address=10.138.94.200 mac-address=00:00:00:00:00:00 client-id=BRGMarcC server=dhcp-wlan3
add address=10.138.94.201 mac-address=00:00:00:00:00:00 client-id=AVBepNouRd1 server=dhcp-wlan3
add address=10.138.94.202 mac-address=00:00:00:00:00:00 client-id=AVMarcAnna server=dhcp-wlan3
add address=10.138.94.203 mac-address=04:18:D6:E4:CA:E8 client-id=AVCampsComa server=dhcp-wlan3
add address=10.138.94.204 mac-address=04:18:D6:2A:E8:2D client-id=AVAvia33Rd1 server=dhcp-wlan3
#
:delay 1
#
# Radio#: 3 AVSalvansAP3
/interface wireless set wlan4 name="wlan4" \
radio-name="AVSalvansAP3" mode=ap-bridge ssid="guifi.net-AVSalvansAP3" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5520 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.94.225/27"] do={remove $i}
/ ip address add address=10.138.94.225/27 network=10.138.94.224 broadcast=10.138.94.255 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.94.224/27] do={/routing bgp network remove $i;}
add network=10.138.94.224/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.94.224/27] do={/routing ospf network remove $i;}
add network=10.138.94.224/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.138.94.231-10.138.94.254
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.94.224/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.94.224/27 gateway=10.138.94.225 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.94.226 mac-address=00:00:00:00:00:00 client-id=AVSalvansAP3 server=dhcp-wlan4
add address=10.138.94.227 mac-address=00:00:00:00:00:00 client-id=AVJuli server=dhcp-wlan4
add address=10.138.94.228 mac-address=00:00:00:00:00:00 client-id=AVVolemRd1 server=dhcp-wlan4
add address=10.138.94.229 mac-address=00:27:22:C6:8F:5F client-id=AVGabi server=dhcp-wlan4
add address=10.138.94.230 mac-address=00:27:22:2A:6C:DC client-id=PauCasals76Rd1 server=dhcp-wlan4
add address=10.138.94.231 mac-address=00:00:00:00:00:00 client-id=AVTeuleria6Rd1 server=dhcp-wlan4
add address=10.138.94.232 mac-address=00:15:6D:82:7A:C2 client-id=AVTorrePiquerRd1 server=dhcp-wlan4
add address=10.138.94.233 mac-address=00:00:00:00:00:00 client-id=AVSobreestrada server=dhcp-wlan4
add address=10.138.94.234 mac-address=00:00:00:00:00:00 client-id=CAPGrau server=dhcp-wlan4
add address=10.138.94.235 mac-address=00:00:00:00:00:00 client-id=AVGraneRd1 server=dhcp-wlan4
add address=10.138.94.236 mac-address=00:00:00:00:00:00 client-id=AVDPalauRd1 server=dhcp-wlan4
add address=10.138.94.237 mac-address=00:00:00:00:00:00 client-id=CAPGrau2Rd1 server=dhcp-wlan4
add address=10.138.94.238 mac-address=04:18:D6:5E:2B:8E client-id=AVPauCasals76Rd2 server=dhcp-wlan4
add address=10.138.94.239 mac-address=04:18:D6:4C:88:FA client-id=AVsantisidre22Rd1 server=dhcp-wlan4
add address=10.138.94.240 mac-address=F0:9F:C2:40:4B:E8 client-id=AVmelgo1Rd1 server=dhcp-wlan4
#
:delay 1
#
# Radio#: 4 wds-AVVSlvns-AVAjunt
/interface wireless set wlan5 name="wlan5" \
radio-name="wds-AVVSlvns-AVAjunt" mode=ap-bridge ssid="guifi.net-wds-AVVSlvns-AVAjunt" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5500 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdswds-AVVSlvns-AVAjunt
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan5] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 5 wds-AVVSlvns-BRGPons
/interface wireless set wlan6 name="wlan6" \
radio-name="wds-AVVSlvns-BRGPons" mode=ap-bridge ssid="guifi.net-wds-AVVSlvns-BRGPons" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5680 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds-SalvansPons
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan6] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BRGPonsST" master-interface=wlan6 wds-address=04:18:D6:24:9B:C5 disabled=no
/ ip address add address=172.25.39.36/29 network=172.25.39.32 broadcast=172.25.39.39 interface=wds_BRGPonsST disabled=no comment="wds_BRGPonsST"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BRGPonsST] do={/routing ospf interface remove $i;}
add interface=wds_BRGPonsST
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.39.32/29] do={/routing ospf network remove $i;}
add network=172.25.39.32/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BRGPonsST] do={/routing bgp peer remove $i;}
add name="BRGPonsST" instance=default remote-address=172.25.39.35 remote-as=29116 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 6 wdsAVSlvns2011Serrapin
/interface wireless set wlan7 name="wlan7" \
radio-name="wdsAVSlvns2011Serrapin" mode=ap-bridge ssid="guifi.net-wdsAVSlvns2011Serrapin" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdswdsAVSlvns2011Serrapin
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan7] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_AVSerrapinyanaST" master-interface=wlan7 wds-address=02:0C:42:2B:50:23 disabled=no
/ ip address add address=172.25.61.201/29 network=172.25.61.200 broadcast=172.25.61.207 interface=wds_AVSerrapinyanaST disabled=no comment="wds_AVSerrapinyanaST"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_AVSerrapinyanaST] do={/routing ospf interface remove $i;}
add interface=wds_AVSerrapinyanaST
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.61.200/29] do={/routing ospf network remove $i;}
add network=172.25.61.200/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=AVSerrapinyanaST] do={/routing bgp peer remove $i;}
add name="AVSerrapinyanaST" instance=default remote-address=172.25.61.206 remote-as=23872 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
:foreach i in [/ip address find address="10.91.186.65/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.91.186.65/27 network=10.91.186.64 broadcast=10.91.186.95 interface=ether1 disabled=no comment=""
:foreach i in [/ip address find address="10.91.186.97/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.91.186.97/27 network=10.91.186.96 broadcast=10.91.186.127 interface=ether2 disabled=no comment=""
:foreach i in [/ip address find address="10.91.186.129/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.91.186.129/27 network=10.91.186.128 broadcast=10.91.186.159 interface=ether3 disabled=no comment=""
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.91.186.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.91.186.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.91.186.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=69897 router-id=10.91.186.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.91.186.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 69897-AVSalvansRB2011LS executed."
/