# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 66671-TDLTaborDipST3 going to be executed."
#
# Configuration for RouterOSv6.x
# Trasto: 66671-TDLTaborDipST3
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=TDLTaborDipST3
#
# DNS (client & server cache) zone: 22900
/ip dns set servers=10.139.130.34 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 22900
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.203.104
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="TDLTaborDip" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether1] do={/routing ospf interface remove $i;}
add interface=ether1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.51.176/30] do={/routing ospf network remove $i;}
add network=172.25.51.176/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipST2] do={/routing bgp peer remove $i;}
add name="TDLTaborDipST2" instance=default remote-address=172.25.51.178 remote-as=52055 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.51.177/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.51.177/30 network=172.25.51.176 broadcast=172.25.51.179 interface=ether1 disabled=yes comment="TDLTaborDipST2"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether2] do={/routing ospf interface remove $i;}
add interface=ether2
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.51.180/30] do={/routing ospf network remove $i;}
add network=172.25.51.180/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipST1] do={/routing bgp peer remove $i;}
add name="TDLTaborDipST1" instance=default remote-address=172.25.51.182 remote-as=22591 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.51.181/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.51.181/30 network=172.25.51.180 broadcast=172.25.51.183 interface=ether2 disabled=yes comment="TDLTaborDipST1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether3] do={/routing ospf interface remove $i;}
add interface=ether3
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.66.0/29] do={/routing ospf network remove $i;}
add network=172.25.66.0/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipNanoStation1] do={/routing bgp peer remove $i;}
add name="TDLTaborDipNanoStation1" instance=default remote-address=172.25.66.2 remote-as=26779 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.66.1/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.66.1/29 network=172.25.66.0 broadcast=172.25.66.7 interface=ether3 disabled=yes comment="TDLTaborDipNanoStation1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether4] do={/routing ospf interface remove $i;}
add interface=ether4
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.66.8/29] do={/routing ospf network remove $i;}
add network=172.25.66.8/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipNanoBeam1] do={/routing bgp peer remove $i;}
add name="TDLTaborDipNanoBeam1" instance=default remote-address=172.25.66.10 remote-as=69584 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.66.9/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.66.9/29 network=172.25.66.8 broadcast=172.25.66.15 interface=ether4 disabled=yes comment="TDLTaborDipNanoBeam1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether5] do={/routing ospf interface remove $i;}
add interface=ether5
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.66.16/29] do={/routing ospf network remove $i;}
add network=172.25.66.16/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipNanoBeam2] do={/routing bgp peer remove $i;}
add name="TDLTaborDipNanoBeam2" instance=default remote-address=172.25.66.18 remote-as=69585 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.66.17/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.66.17/29 network=172.25.66.16 broadcast=172.25.66.23 interface=ether5 disabled=yes comment="TDLTaborDipNanoBeam2"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether6] do={/routing ospf interface remove $i;}
add interface=ether6
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.37.120/30] do={/routing ospf network remove $i;}
add network=172.25.37.120/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipRocketRd1] do={/routing bgp peer remove $i;}
add name="TDLTaborDipRocketRd1" instance=default remote-address=172.25.37.122 remote-as=83902 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.37.121/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.37.121/30 network=172.25.37.120 broadcast=172.25.37.123 interface=ether6 disabled=yes comment="TDLTaborDipRocketRd1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether7] do={/routing ospf interface remove $i;}
add interface=ether7
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.38.188/30] do={/routing ospf network remove $i;}
add network=172.25.38.188/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipRocketRd2] do={/routing bgp peer remove $i;}
add name="TDLTaborDipRocketRd2" instance=default remote-address=172.25.38.190 remote-as=83915 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.38.189/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.38.189/30 network=172.25.38.188 broadcast=172.25.38.191 interface=ether7 disabled=yes comment="TDLTaborDipRocketRd2"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether8] do={/routing ospf interface remove $i;}
add interface=ether8
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.39.116/30] do={/routing ospf network remove $i;}
add network=172.25.39.116/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=TDLTaborDipRocketRd3] do={/routing bgp peer remove $i;}
add name="TDLTaborDipRocketRd3" instance=default remote-address=172.25.39.118 remote-as=83918 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.39.117/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.39.117/30 network=172.25.39.116 broadcast=172.25.39.119 interface=ether8 disabled=yes comment="TDLTaborDipRocketRd3"
:foreach i in [/ip address find address="10.138.238.1/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.138.238.1/27 network=10.138.238.0 broadcast=10.138.238.31 interface=ether13 disabled=no comment="TDLTaborDipRocketRd3"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.138.238.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.138.238.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.138.238.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=66671 router-id=10.138.238.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.138.238.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 66671-TDLTaborDipST3 executed."
/