# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 5323-SMCElMontparAPs going to be executed."
#
# Configuration for RouterOSv5.x
# Trasto: 5323-SMCElMontparAPs
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=SMCElMontparAPs
#
# DNS (client & server cache) zone: 6852
/ip dns set servers=10.138.97.2,10.138.0.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 6852
/system ntp client set enabled=yes mode=unicast primary-ntp=10.138.97.2 secondary-ntp=10.138.0.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="SMCElMontpar" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 SMCElMontparAP
/interface wireless set wlan1 name="wlan1" \
radio-name="SMCElMontparAP" mode=ap-bridge ssid="guifi.net-SMCElMontparAP" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2462 \
dfs-mode=none \
wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: HotSpot
#
# HotSpot
/interface wireless
:foreach i in [find name=hotspot1] do={remove $i}
add name="hotspot1" arp=enabled master-interface=wlan1 ssid="guifi.net-AccesObert" disabled="no"
/ip address
:foreach i in [find address="192.168.100.1/24"] do={remove $i}
/ip address add address=192.168.100.1/24 interface=hotspot1 disabled=no
/ip pool
:foreach i in [find name=hs-pool-100] do={remove $i}
add name="hs-pool-100" ranges=192.168.100.2-192.168.100.254
/ip dhcp-server
:foreach i in [find name=hs-dhcp-100] do={remove $i}
add name="hs-dhcp-100" interface=hotspot1 lease-time=1h address-pool=hs-pool-100 bootp-support=static authoritative=after-2sec-delay disabled=no
/ip dhcp-server network
:foreach i in [find address="192.168.100.0/24"] do={remove $i}
add address=192.168.100.0/24 gateway=192.168.100.1 domain=guifi.net comment=dhcp-0
/ip hotspot profile
:foreach i in [find name=hsprof1] do={remove $i}
add name="hsprof1" hotspot-address=192.168.100.1 dns-name="guests.guifi.net" html-directory=hotspot smtp-server=0.0.0.0 login-by=http-pap,trial split-user-domain=no trial-uptime=30m/1d trial-user-profile=default use-radius=no
/ip hotspot user profile
set default name="default" advertise-url=http://guifi.net/trespassos/
/ip hotspot
:foreach i in [find name=hotspot1] do={remove $i}
add name="hotspot1" interface=hotspot1 address-pool=hs-pool-100 profile=hsprof1 idle-timeout=5m keepalive-timeout=none addresses-per-mac=2 disabled=no
# end of HotSpot
:delay 1
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.138.97.65/27"] do={remove $i}
/ ip address add address=10.138.97.65/27 network=10.138.97.64 broadcast=10.138.97.95 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.97.64/27] do={/routing bgp network remove $i;}
add network=10.138.97.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.97.64/27] do={/routing ospf network remove $i;}
add network=10.138.97.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.138.97.71-10.138.97.94
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.97.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.97.64/27 gateway=10.138.97.65 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.97.66 mac-address=00:1A:70:4E:DD:E9 client-id=SMCLaViladevallRadio1 server=dhcp-wLan/Lan
add address=10.138.97.68 mac-address=00:1A:70:4F:1E:6A client-id=SMCLesComesCasadiegoRadio2 server=dhcp-wLan/Lan
add address=10.138.97.69 mac-address=00:15:6D:AB:F0:8D client-id=SMCLesComesCasacuberRadio1 server=dhcp-wLan/Lan
add address=10.138.97.70 mac-address=00:1C:10:13:99:41 client-id=SMCCanVisoVellRadio1 server=dhcp-wLan/Lan
add address=10.138.97.71 mac-address=00:1C:10:13:B1:35 client-id=SMCLesComesRosaFontRadio1 server=dhcp-wLan/Lan
add address=10.138.97.72 mac-address=00:1C:10:13:98:18 client-id=SMCLesComesToranRadio1 server=dhcp-wLan/Lan
add address=10.138.97.73 mac-address=00:1C:10:13:97:D0 client-id=SMCLesComesJmTantinaRadio1 server=dhcp-wLan/Lan
add address=10.138.97.74 mac-address=00:1A:70:7B:5B:32 client-id=SMCLesComesIVinasRadio1 server=dhcp-wLan/Lan
add address=10.138.97.75 mac-address=68:72:51:1A:97:DC client-id=SMCmontseny11Rd2 server=dhcp-wLan/Lan
add address=10.138.97.76 mac-address=00:15:6D:AC:DE:01 client-id=CNTSantMarti39Rd1 server=dhcp-wLan/Lan
add address=10.138.97.77 mac-address=00:16:01:AE:E8:46 client-id=SMCLesComesAgustiRadio1 server=dhcp-wLan/Lan
add address=10.138.97.79 mac-address=24:A4:3C:D0:95:7D client-id=SMCCanVisoRd1 server=dhcp-wLan/Lan
add address=10.138.97.80 mac-address=00:27:22:42:2C:A4 client-id=SMCRPradoRd1 server=dhcp-wLan/Lan
add address=10.138.97.81 mac-address=00:16:01:F2:2C:35 client-id=hostaletsppuigRadio1 server=dhcp-wLan/Lan
add address=10.138.97.82 mac-address=00:15:6D:D9:22:D4 client-id=SMCCanGafesRd1 server=dhcp-wLan/Lan
add address=10.138.97.83 mac-address=00:1D:7E:60:92:4A client-id=SEVAPICORadio1 server=dhcp-wLan/Lan
add address=10.138.97.84 mac-address=00:1C:10:13:99:43 client-id=SMCLesComes2 server=dhcp-wLan/Lan
add address=10.138.97.85 mac-address=00:16:E6:3C:95:FA client-id=NodoJCARLESRd1 server=dhcp-wLan/Lan
add address=10.138.97.86 mac-address=00:15:6D:E8:CC:19 client-id=SMCcntdsRd1 server=dhcp-wLan/Lan
add address=10.138.97.87 mac-address=00:15:6D:E8:CC:53 client-id=CNTPuigDRd1 server=dhcp-wLan/Lan
add address=10.138.97.88 mac-address=00:23:CD:1B:9D:B7 client-id=SMCElMontparAPRd1 server=dhcp-wLan/Lan
add address=10.138.97.89 mac-address=00:16:B6:40:DD:69 client-id=SevaMaroyaRd1 server=dhcp-wLan/Lan
add address=10.138.97.90 mac-address=00:0F:66:37:45:4C client-id=cmontseny11Rd1 server=dhcp-wLan/Lan
add address=10.138.97.91 mac-address=00:0C:42:13:E1:B2 client-id=CNTJaumeFont server=dhcp-wLan/Lan
add address=10.138.97.92 mac-address=00:1D:7E:3A:47:51 client-id=CNTStFeliuRadio1 server=dhcp-wLan/Lan
add address=10.138.97.93 mac-address=00:1D:7E:3A:3E:90 client-id=HostaletsBaulenasRadio1 server=dhcp-wLan/Lan
add address=10.138.97.94 mac-address=00:27:22:2C:27:C3 client-id=SMCLesComesAgustiRd2 server=dhcp-wLan/Lan
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 2 SMCElMontparSMCCanBorla
/interface wireless set wlan3 name="wlan3" \
radio-name="SMCElMontparSMCCanBorla" mode=ap-bridge ssid="guifi.net-SMCElMontparSMCCanBorla" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=24 \
frequency=5680 \
dfs-mode=none \
wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_SMCCanBorlaST" master-interface=wlan3 wds-address=00:1A:4D:21:10:05 disabled=no
/ ip address add address=172.25.6.46/30 network=172.25.6.44 broadcast=172.25.6.47 interface=wds_SMCCanBorlaST disabled=no comment="wds_SMCCanBorlaST"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_SMCCanBorlaST] do={/routing ospf interface remove $i;}
add interface=wds_SMCCanBorlaST
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.6.44/30] do={/routing ospf network remove $i;}
add network=172.25.6.44/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=SMCCanBorlaST] do={/routing bgp peer remove $i;}
add name="SMCCanBorlaST" instance=default remote-address=172.25.6.45 remote-as=5325 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether3] do={/routing ospf interface remove $i;}
add interface=ether3
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.1.44/30] do={/routing ospf network remove $i;}
add network=172.25.1.44/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=SMCElMontparST] do={/routing bgp peer remove $i;}
add name="SMCElMontparST" instance=default remote-address=172.25.1.45 remote-as=54231 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.25.1.46/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.1.46/30 network=172.25.1.44 broadcast=172.25.1.47 interface=ether3 disabled=no comment="SMCElMontparST"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.138.97.65 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.138.97.65" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.138.97.65"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=5323 router-id=10.138.97.65 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.138.97.65 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 5323-SMCElMontparAPs executed."
/