# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 28283-OlostDipST-03 going to be executed."
#
# Configuration for RouterOSv5.x
# Trasto: 28283-OlostDipST-03
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=OlostDipST-03
#
# DNS (client & server cache) zone: 2458
/ip dns set servers=10.138.120.66,10.138.0.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 2458
/system ntp client set enabled=yes mode=unicast primary-ntp=10.138.57.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="OlostDip" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 OlostDip-LtoCCivic
/interface wireless set wlan1 name="wlan1" \
radio-name="OlostDip-LtoCCivic" mode=ap-bridge ssid="guifi.net-OlostDip-LtoCCivic" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5250 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsOlostDip-LtoCCivic
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_LaTorreCentreCivicOmniTic" master-interface=wlan1 wds-address=99:99:99:99:99:99 disabled=no
/ ip address add address=172.25.50.233/29 network=172.25.50.232 broadcast=172.25.50.239 interface=wds_LaTorreCentreCivicOmniTic disabled=no comment="wds_LaTorreCentreCivicOmniTic"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_LaTorreCentreCivicOmniTic] do={/routing ospf interface remove $i;}
add interface=wds_LaTorreCentreCivicOmniTic
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.50.232/29] do={/routing ospf network remove $i;}
add network=172.25.50.232/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LaTorreCentreCivicOmniTic] do={/routing bgp peer remove $i;}
add name="LaTorreCentreCivicOmniTic" instance=default remote-address=172.25.50.236 remote-as=43117 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 1 OlostDip-OlostAj
/interface wireless set wlan2 name="wlan2" \
radio-name="OlostDip-OlostAj" mode=ap-bridge ssid="guifi.net-OlostDip-OlostAj" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsOlostDipSmaDip
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_SMADipST02" master-interface=wlan2 wds-address=99:99:99:99:99:99 disabled=no
/ ip address add address=172.25.146.76/29 network=172.25.146.72 broadcast=172.25.146.79 interface=wds_SMADipST02 disabled=no comment="wds_SMADipST02"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_SMADipST02] do={/routing ospf interface remove $i;}
add interface=wds_SMADipST02
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.146.72/29] do={/routing ospf network remove $i;}
add network=172.25.146.72/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=SMADipST02] do={/routing bgp peer remove $i;}
add name="SMADipST02" instance=default remote-address=172.25.146.79 remote-as=70311 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 2 OlostDipSmaDip
/interface wireless set wlan3 name="wlan3" \
radio-name="OlostDipSmaDip" mode=ap-bridge ssid="guifi.net-OlostDipSmaDip" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsOlostDipST3SBGTorre
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_SBGTorreST01" master-interface=wlan3 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.1.17/29 network=172.25.1.16 broadcast=172.25.1.23 interface=wds_SBGTorreST01 disabled=no comment="wds_SBGTorreST01"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_SBGTorreST01] do={/routing ospf interface remove $i;}
add interface=wds_SBGTorreST01
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.1.16/29] do={/routing ospf network remove $i;}
add network=172.25.1.16/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=SBGTorreST01] do={/routing bgp peer remove $i;}
add name="SBGTorreST01" instance=default remote-address=172.25.1.20 remote-as=73722 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 3 OlostDip-SFSBruixes
/interface wireless set wlan4 name="wlan4" \
radio-name="OlostDip-SFSBruixes" mode=ap-bridge ssid="guifi.net-OlostDip-SFSBruixes" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsOlostDip-SFSBruixes
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan4] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_SFSBruixesOlostDip" master-interface=wlan4 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.67.12/29 network=172.25.67.8 broadcast=172.25.67.15 interface=wds_SFSBruixesOlostDip disabled=no comment="wds_SFSBruixesOlostDip"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_SFSBruixesOlostDip] do={/routing ospf interface remove $i;}
add interface=wds_SFSBruixesOlostDip
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.67.8/29] do={/routing ospf network remove $i;}
add network=172.25.67.8/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=SFSBruixesOlostDip] do={/routing bgp peer remove $i;}
add name="SFSBruixesOlostDip" instance=default remote-address=172.25.67.9 remote-as=83035 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 4 OlostDip-OlostRoca
/interface wireless set wlan5 name="wlan5" \
radio-name="OlostDip-OlostRoca" mode=ap-bridge ssid="guifi.net-OlostDip-OlostRoca" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
#
# Radio#: 5 OlostDipAP51SE
/interface wireless set wlan6 name="wlan6" \
radio-name="OlostDipAP51SE" mode=ap-bridge ssid="guifi.net-OlostDipAP51SE" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsOlostDipAP51SE
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan6] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wdsOlostDipAP51SE2
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan6] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.122.161/27"] do={remove $i}
/ ip address add address=10.138.122.161/27 network=10.138.122.160 broadcast=10.138.122.191 interface=wlan6 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.122.160/27] do={/routing bgp network remove $i;}
add network=10.138.122.160/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan6] do={/routing ospf interface remove $i;}
add interface=wlan6
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.122.160/27] do={/routing ospf network remove $i;}
add network=10.138.122.160/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan6] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan6 ranges=10.138.122.167-10.138.122.190
:foreach i in [/ip dhcp-server find name=dhcp-wlan6] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan6 interface=wlan6 address-pool=dhcp-wlan6 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.122.160/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.122.160/27 gateway=10.138.122.161 domain=guifi.net comment=dhcp-wlan6
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.120.33/28"] do={remove $i}
/ ip address add address=10.138.120.33/28 network=10.138.120.32 broadcast=10.138.120.47 interface=wlan6 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.120.32/28] do={/routing bgp network remove $i;}
add network=10.138.120.32/28 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan6] do={/routing ospf interface remove $i;}
add interface=wlan6
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.120.32/28] do={/routing ospf network remove $i;}
add network=10.138.120.32/28 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan6] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan6 ranges=10.138.120.39-10.138.120.46
:foreach i in [/ip dhcp-server find name=dhcp-wlan6] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan6 interface=wlan6 address-pool=dhcp-wlan6 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.120.32/28"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.120.32/28 gateway=10.138.120.33 domain=guifi.net comment=dhcp-wlan6
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.120.46 mac-address=00:00:00:00:00:00 client-id=OlostEDAROlostRd1 server=dhcp-wlan6
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.139.251.17/28"] do={remove $i}
/ ip address add address=10.139.251.17/28 network=10.139.251.16 broadcast=10.139.251.31 interface=wlan6 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.139.251.16/28] do={/routing bgp network remove $i;}
add network=10.139.251.16/28 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan6] do={/routing ospf interface remove $i;}
add interface=wlan6
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.251.16/28] do={/routing ospf network remove $i;}
add network=10.139.251.16/28 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan6] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan6 ranges=10.139.251.23-10.139.251.30
:foreach i in [/ip dhcp-server find name=dhcp-wlan6] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan6 interface=wlan6 address-pool=dhcp-wlan6 disabled=no
:foreach i in [/ip dhcp-server network find address="10.139.251.16/28"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.139.251.16/28 gateway=10.139.251.17 domain=guifi.net comment=dhcp-wlan6
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
#
# Radio#: 6 OlostDip-SCJ
/interface wireless set wlan7 name="wlan7" \
radio-name="OlostDip-SCJ" mode=ap-bridge ssid="guifi.net-OlostDip-SCJ" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsOlostlstDpGurbMundo
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan7] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_rou01stprdcpdscjgoufonecat" master-interface=wlan7 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.0.238/30 network=172.25.0.236 broadcast=172.25.0.239 interface=wds_rou01stprdcpdscjgoufonecat disabled=no comment="wds_rou01stprdcpdscjgoufonecat"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_rou01stprdcpdscjgoufonecat] do={/routing ospf interface remove $i;}
add interface=wds_rou01stprdcpdscjgoufonecat
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.0.236/30] do={/routing ospf network remove $i;}
add network=172.25.0.236/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=rou01stprdcpdscjgoufonecat] do={/routing bgp peer remove $i;}
add name="rou01stprdcpdscjgoufonecat" instance=default remote-address=172.25.0.237 remote-as=106575 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether5] do={/routing ospf interface remove $i;}
add interface=ether5
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.34.220/30] do={/routing ospf network remove $i;}
add network=172.25.34.220/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=OLSTDipST1] do={/routing bgp peer remove $i;}
add name="OLSTDipST1" instance=default remote-address=172.25.34.222 remote-as=3061 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.25.34.221/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.34.221/30 network=172.25.34.220 broadcast=172.25.34.223 interface=ether5 disabled=no comment="OLSTDipST1"
:foreach i in [/ip address find address="10.139.250.53/32"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.139.250.53/32 network=10.139.250.53 broadcast=10.139.250.53 interface=ether3 disabled=no comment="OLSTDipST1"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.250.53 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.250.53" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.250.53"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=28283 router-id=10.139.250.53 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.139.250.53 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 28283-OlostDipST-03 executed."
/