# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 20205-NVTCampanarRd1 going to be executed."
#
# Configuration for RouterOSv5.x
# Trasto: 20205-NVTCampanarRd1
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=NVTCampanarRd1
#
# DNS (client & server cache) zone: 17203
/ip dns set servers=10.139.33.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 17203
/system ntp client set enabled=yes mode=unicast primary-ntp=10.139.38.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="NVTCampanar" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 NavataOmni
/interface wireless set wlan1 name="wlan1" \
radio-name="NavataOmni" mode=ap-bridge ssid="guifi.net-NavataOmni" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2412 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsNavataOmni
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.139.186.1/27"] do={remove $i}
/ ip address add address=10.139.186.1/27 network=10.139.186.0 broadcast=10.139.186.31 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.139.186.0/27] do={/routing bgp network remove $i;}
add network=10.139.186.0/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.186.0/27] do={/routing ospf network remove $i;}
add network=10.139.186.0/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.139.186.7-10.139.186.30
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.139.186.0/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.139.186.0/27 gateway=10.139.186.1 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.139.186.3 mac-address=00:15:6D:3A:65:11 client-id=NVTNou4Rd1 server=dhcp-wLan/Lan
add address=10.139.186.4 mac-address=00:15:6D:F2:9D:D2 client-id=NVTPerolers25 server=dhcp-wLan/Lan
add address=10.139.186.5 mac-address=00:15:6D:82:33:69 client-id=NVTmontRd1 server=dhcp-wLan/Lan
add address=10.139.186.6 mac-address=00:27:22:04:4A:03 client-id=NVTCasamor6Rd1 server=dhcp-wLan/Lan
add address=10.139.186.7 mac-address=00:15:6D:60:66:F3 client-id=NVTCanelles6Rd1 server=dhcp-wLan/Lan
add address=10.139.186.8 mac-address=00:0C:42:8F:42:26 client-id=NVTCabanelles21Rd1 server=dhcp-wLan/Lan
add address=10.139.186.9 mac-address=00:15:6D:60:1C:D0 client-id=NVTOlolt10Rd1 server=dhcp-wLan/Lan
add address=10.139.186.10 mac-address=00:15:6D:60:66:07 client-id=NVTOlot40Rd1 server=dhcp-wLan/Lan
add address=10.139.186.13 mac-address=00:15:6D:3A:60:8D client-id=NVTCreu6Rd1 server=dhcp-wLan/Lan
add address=10.139.186.14 mac-address=00:15:6D:3A:60:8B client-id=NVTPadroRd1 server=dhcp-wLan/Lan
add address=10.139.186.15 mac-address=00:27:22:04:47:2A client-id=NVTPerolers9Rd1 server=dhcp-wLan/Lan
add address=10.139.186.17 mac-address=00:27:22:CC:7A:22 client-id=NVTCarme17Rd1 server=dhcp-wLan/Lan
add address=10.139.186.18 mac-address=00:27:22:64:C6:97 client-id=NVTOlot17Rd1 server=dhcp-wLan/Lan
add address=10.139.186.19 mac-address=00:27:22:CE:EC:F3 client-id=NVTMasGarrigaRd1 server=dhcp-wLan/Lan
add address=10.139.186.20 mac-address=DC:9F:DB:08:DA:E1 client-id=NVTOlot15Rd1 server=dhcp-wLan/Lan
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.186.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.186.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.186.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=20205 router-id=10.139.186.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.139.186.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 20205-NVTCampanarRd1 executed."
/