# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 16376-FIGMVallcarqueraRB750UP going to be executed."
#
# Configuration for RouterOSv6.x
# Trasto: 16376-FIGMVallcarqueraRB750UP
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=FIGMVallcarqueraRB750UP
#
# DNS (client & server cache) zone: 12328
/ip dns set servers=10.139.121.34,10.138.97.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 12328
/system ntp client set enabled=yes mode=unicast primary-ntp=10.138.97.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="FIGMVallcarquera" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 FMonFGMVllcrqrRd1AP0
/interface wireless set wlan1 name="wlan1" \
radio-name="FMonFGMVllcrqrRd1AP0" mode=ap-bridge ssid="guifi.net-FMonFGMVllcrqrRd1AP0" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5580 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsFMonFGMVllcrqrRd1AP0
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.139.138.65/27"] do={remove $i}
/ ip address add address=10.139.138.65/27 network=10.139.138.64 broadcast=10.139.138.95 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.139.138.64/27] do={/routing bgp network remove $i;}
add network=10.139.138.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.138.64/27] do={/routing ospf network remove $i;}
add network=10.139.138.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.139.138.71-10.139.138.94
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.139.138.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.139.138.64/27 gateway=10.139.138.65 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.139.138.66 mac-address=00:0C:42:64:0E:95 client-id=FIGcangeroniRd1 server=dhcp-wLan/Lan
add address=10.139.138.67 mac-address=4C:5E:0C:DF:F8:21 client-id=FigCanViletaRd1 server=dhcp-wLan/Lan
add address=10.139.138.68 mac-address=00:15:6D:9C:82:07 client-id=FIGVllcrqrCMRd1 server=dhcp-wLan/Lan
add address=10.139.138.69 mac-address=00:15:6D:B0:2B:72 client-id=FIGMIvonneRd1 server=dhcp-wLan/Lan
add address=10.139.138.70 mac-address=00:00:00:00:00:00 client-id=FIGCanMestresRd1 server=dhcp-wLan/Lan
add address=10.139.138.71 mac-address=4C:5E:0C:A1:6B:84 client-id=FIGVllcqrOriolRd1 server=dhcp-wLan/Lan
add address=10.139.138.72 mac-address=D4:CA:6D:BD:BD:B3 client-id=FIGCanRufaRd1 server=dhcp-wLan/Lan
add address=10.139.138.73 mac-address=00:27:22:72:27:5E client-id=FIGMarcRd1 server=dhcp-wLan/Lan
add address=10.139.138.74 mac-address=DC:9F:DB:74:08:D4 client-id=FIGCanGrauVallcarqueRd1 server=dhcp-wLan/Lan
add address=10.139.138.75 mac-address=00:15:6D:9A:99:31 client-id=FIGVllcrqrCM1Rd1 server=dhcp-wLan/Lan
add address=10.139.138.76 mac-address=00:00:00:00:00:00 client-id=FIGCanBoscRd1 server=dhcp-wLan/Lan
add address=10.139.138.77 mac-address=00:00:00:00:00:00 client-id=FIGMVallcarqueraAP server=dhcp-wLan/Lan
add address=10.139.138.78 mac-address=00:00:00:00:00:00 client-id=FIGMVallcarqueraNB server=dhcp-wLan/Lan
add address=10.139.138.79 mac-address=4C:5E:0C:05:B5:CD client-id=FIGCanDosriusRd1 server=dhcp-wLan/Lan
add address=10.139.138.80 mac-address=00:00:00:00:00:00 client-id=FgCnGlRd1 server=dhcp-wLan/Lan
add address=10.139.138.81 mac-address=00:00:00:00:00:00 client-id=FgCnVlt2Rd1 server=dhcp-wLan/Lan
add address=10.139.138.82 mac-address=00:00:00:00:00:00 client-id=FigVicentePRd1 server=dhcp-wLan/Lan
add address=10.139.138.83 mac-address=00:00:00:00:00:00 client-id=FIGCalMestresRd1 server=dhcp-wLan/Lan
add address=10.139.138.84 mac-address=00:00:00:00:00:00 client-id=FIGCanCumicuRd1 server=dhcp-wLan/Lan
add address=10.139.138.86 mac-address=00:00:00:00:00:00 client-id=FgVllcrqrSsnRd1 server=dhcp-wLan/Lan
add address=10.139.138.87 mac-address=00:00:00:00:00:00 client-id=FIGDisaminatSNRd1 server=dhcp-wLan/Lan
add address=10.139.138.88 mac-address=00:00:00:00:00:00 client-id=FIGCanValentiRd1 server=dhcp-wLan/Lan
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_FIGMCanBoscRd1" master-interface=wlan1 wds-address=00:01:02:03:04:05 disabled=no
/ ip address add address=172.25.37.101/30 network=172.25.37.100 broadcast=172.25.37.103 interface=wds_FIGMCanBoscRd1 disabled=no comment="wds_FIGMCanBoscRd1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_FIGMCanBoscRd1] do={/routing ospf interface remove $i;}
add interface=wds_FIGMCanBoscRd1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.37.100/30] do={/routing ospf network remove $i;}
add network=172.25.37.100/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=FIGMCanBoscRd1] do={/routing bgp peer remove $i;}
add name="FIGMCanBoscRd1" instance=default remote-address=172.25.37.102 remote-as=16198 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 1 FGMVllcrqr-FGMCnColl
/interface wireless set wlan2 name="wlan2" \
radio-name="FGMVllcrqr-FGMCnColl" mode=ap-bridge ssid="guifi.net-FGMVllcrqr-FGMCnColl" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=21 \
frequency=5685 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsFGMVllcrqr-FGMCnColl
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_FIGMCanCollRB750" master-interface=wlan2 wds-address=00:0C:42:2C:A9:1F disabled=no
/ ip address add address=172.25.65.89/29 network=172.25.65.88 broadcast=172.25.65.95 interface=wds_FIGMCanCollRB750 disabled=no comment="wds_FIGMCanCollRB750"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_FIGMCanCollRB750] do={/routing ospf interface remove $i;}
add interface=wds_FIGMCanCollRB750
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.65.88/29] do={/routing ospf network remove $i;}
add network=172.25.65.88/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=FIGMCanCollRB750] do={/routing bgp peer remove $i;}
add name="FIGMCanCollRB750" instance=default remote-address=172.25.65.92 remote-as=17053 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.138.65 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.138.65" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.138.65"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=16376 router-id=10.139.138.65 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.139.138.65 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 16376-FIGMVallcarqueraRB750UP executed."
/