# Generat per a:
# RouterOSv3.x
:log info "Unsolclic for 12786-CTC going to be executed."
#
# Configuration for RouterOSv3.x
# Trasto: 12786-CTC
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=CTC
#
# DNS (client & server cache) zone: 15561
/ip dns set primary-dns=10.145.32.11 secondary-dns=10.145.32.12 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 15561
/system ntp client set enabled=yes mode=unicast primary-ntp=10.145.32.14
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp set contact="guifi@guifi.net" enabled=yes location="CTC-HUB"
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 msf2-CTC1.masquefa.net
/interface wireless set wlan1 name="wlan1" \
radio-name="msf2-CTC1.masquefa.net" mode=ap-bridge ssid="guifi.net-msf2-CTC1.masquefa.net" \
band="2.4ghz-b" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2412 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 1 msf2-CTC2-masquefa.net
/interface wireless set wlan2 name="wlan2" \
radio-name="msf2-CTC2-masquefa.net" mode=ap-bridge ssid="guifi.net-msf2-CTC2-masquefa.net" \
band="2.4ghz-b" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2462 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.145.44.225/27"] do={remove $i}
/ ip address add address=10.145.44.225/27 network=10.145.44.224 broadcast=10.145.44.255 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.145.44.224/27] do={/routing bgp network remove $i;}
add network=10.145.44.224/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.145.44.224/27] do={/routing ospf network remove $i;}
add network=10.145.44.224/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=10.145.44.231-10.145.44.254
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=no
:foreach i in [/ip dhcp-server network find address="10.145.44.224/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.145.44.224/27 gateway=10.145.44.225 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 2 msf5-CTC1.masquefa.net
/interface wireless set wlan3 name="wlan3" \
radio-name="msf5-CTC1.masquefa.net" mode=ap-bridge ssid="guifi.net-msf5-CTC1.masquefa.net" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5500 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.145.45.1/27"] do={remove $i}
/ ip address add address=10.145.45.1/27 network=10.145.45.0 broadcast=10.145.45.31 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.145.45.0/27] do={/routing bgp network remove $i;}
add network=10.145.45.0/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.145.45.0/27] do={/routing ospf network remove $i;}
add network=10.145.45.0/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=10.145.45.7-10.145.45.30
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=no
:foreach i in [/ip dhcp-server network find address="10.145.45.0/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.145.45.0/27 gateway=10.145.45.1 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 3 msf5-CTC2.masquefa.net
/interface wireless set wlan4 name="wlan4" \
radio-name="msf5-CTC2.masquefa.net" mode=ap-bridge ssid="guifi.net-msf5-CTC2.masquefa.net" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5540 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.145.45.33/27"] do={remove $i}
/ ip address add address=10.145.45.33/27 network=10.145.45.32 broadcast=10.145.45.63 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.145.45.32/27] do={/routing bgp network remove $i;}
add network=10.145.45.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.145.45.32/27] do={/routing ospf network remove $i;}
add network=10.145.45.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.145.45.39-10.145.45.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.145.45.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.145.45.32/27 gateway=10.145.45.33 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan4] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 4 msf5-CTC3.masquefa.net
/interface wireless set wlan5 name="wlan5" \
radio-name="msf5-CTC3.masquefa.net" mode=ap-bridge ssid="guifi.net-msf5-CTC3.masquefa.net" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5515 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan5] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 5 msf2-CTC3.masquefa.net
/interface wireless set wlan6 name="wlan6" \
radio-name="msf2-CTC3.masquefa.net" mode=ap-bridge ssid="guifi.net-msf2-CTC3.masquefa.net" \
band="2.4ghz-b" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2412 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan6] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 6 msf5-CTC4.masquefa.net
/interface wireless set wlan7 name="wlan7" \
radio-name="msf5-CTC4.masquefa.net" mode=ap-bridge ssid="guifi.net-msf5-CTC4.masquefa.net" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.145.48.129/27"] do={remove $i}
/ ip address add address=10.145.48.129/27 network=10.145.48.128 broadcast=10.145.48.159 interface=wlan7 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.145.48.128/27] do={/routing bgp network remove $i;}
add network=10.145.48.128/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan7] do={/routing ospf interface remove $i;}
add interface=wlan7
/ routing ospf network
:foreach i in [/routing ospf network find network=10.145.48.128/27] do={/routing ospf network remove $i;}
add network=10.145.48.128/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan7] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan7 ranges=10.145.48.135-10.145.48.158
:foreach i in [/ip dhcp-server find name=dhcp-wlan7] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan7 interface=wlan7 address-pool=dhcp-wlan7 disabled=no
:foreach i in [/ip dhcp-server network find address="10.145.48.128/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.145.48.128/27 gateway=10.145.48.129 domain=guifi.net comment=dhcp-wlan7
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan7] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 7 msf5-CTC4OK.masquefa.net
/interface wireless set wlan8 name="wlan8" \
radio-name="msf5-CTC4OK.masquefa.net" mode=ap-bridge ssid="guifi.net-msf5-CTC4OK.masquefa.net" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.145.49.65/27"] do={remove $i}
/ ip address add address=10.145.49.65/27 network=10.145.49.64 broadcast=10.145.49.95 interface=wlan8 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.145.49.64/27] do={/routing bgp network remove $i;}
add network=10.145.49.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan8] do={/routing ospf interface remove $i;}
add interface=wlan8
/ routing ospf network
:foreach i in [/routing ospf network find network=10.145.49.64/27] do={/routing ospf network remove $i;}
add network=10.145.49.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan8] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan8 ranges=10.145.49.71-10.145.49.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan8] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan8 interface=wlan8 address-pool=dhcp-wlan8 disabled=no
:foreach i in [/ip dhcp-server network find address="10.145.49.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.145.49.64/27 gateway=10.145.49.65 domain=guifi.net comment=dhcp-wlan8
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan8] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether2] do={/routing ospf interface remove $i;}
add interface=ether2
/ routing ospf network
:foreach i in [/routing ospf network find network=172.17.17.172/30] do={/routing ospf network remove $i;}
add network=172.17.17.172/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=CTCHUB] do={/routing bgp peer remove $i;}
add name="CTCHUB" instance=default remote-address=172.17.17.174 remote-as=22012 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.17.17.173/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.17.17.173/30 network=172.17.17.172 broadcast=172.17.17.175 interface=ether2 disabled=no comment="CTCHUB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether3] do={/routing ospf interface remove $i;}
add interface=ether3
/ routing ospf network
:foreach i in [/routing ospf network find network=172.17.18.192/30] do={/routing ospf network remove $i;}
add network=172.17.18.192/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CTCGateway2] do={/routing bgp peer remove $i;}
add name="CTCGateway2" instance=default remote-address=172.17.18.194 remote-as=53672 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.17.18.193/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.17.18.193/30 network=172.17.18.192 broadcast=172.17.18.195 interface=ether3 disabled=yes comment="CTCGateway2"
:foreach i in [/ip address find address="10.145.45.65/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.145.45.65/27 network=10.145.45.64 broadcast=10.145.45.95 interface=Lan disabled=no comment="CTCGateway2"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.145.45.65 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.145.45.65" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.145.45.65"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=12786 router-id=10.145.45.65 \
redistribute-connected=yes redistribute-static=yes redistribute-rip=yes \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf set router-id=10.145.45.65 distribute-default=never redistribute-connected=no \
redistribute-static=no redistribute-rip=no redistribute-bgp=as-type-1
#
:log info "Unsolclic for 12786-CTC executed."
/